CentOS ServerQueenVPSにyumの導入

Share on Facebook0Share on Google+0Tweet about this on TwitterShare on LinkedIn0

参考 URL URL

ServerQueenでサーバーを借りてみたんだが

初期の状態ではyumが入ってなかった…

 

なんじゃいと思ったけど何しか自分で導入することに

まずはRPM置き場を作っておく。

[root@foo ~]# cd /usr/local/src/
[root@foo src]# mkdir yumrpm
[root@foo src]# cd yumrpm/

ftp://ftp.riken.jp/Linux/centos/5/os/i386/CentOS/
から最新版のyumをGET

 

[root@foo yumrpm]# wget ftp://ftp.riken.jp/Linux/centos/5/os/i386/CentOS/yum-3.2.22-33.el5.centos.noarch.rpm

んでインストールしてみる。

[root@foo yumrpm]# rpm -ivh yum-3.2.22-33.el5.centos.noarch.rpm
warning: yum-3.2.22-33.el5.centos.noarch.rpm: Header V3 DSA signature: NOKEY, key ID e8562897
error: Failed dependencies:
        python-elementtree is needed by yum-3.2.22-33.el5.centos.noarch
        python-iniparse is needed by yum-3.2.22-33.el5.centos.noarch
        python-sqlite is needed by yum-3.2.22-33.el5.centos.noarch
        urlgrabber >= 3.1.0 is needed by yum-3.2.22-33.el5.centos.noarch
        yum-fastestmirror is needed by yum-3.2.22-33.el5.centos.noarch
        yum-metadata-parser >= 1.1.0 is needed by yum-3.2.22-33.el5.centos.noarch

 

がっつり怒られた。

 

必要やと怒られたパッケージを取ってくる。

 

[root@foo yumrpm]# wget ftp://ftp.riken.jp/Linux/centos/5/os/i386/CentOS/python-elementtree-1.2.6-5.i386.rpm
[root@foo yumrpm]# wget ftp://ftp.riken.jp/Linux/centos/5/os/i386/CentOS/python-iniparse-0.2.3-4.el5.noarch.rpm
[root@foo yumrpm]# wget ftp://ftp.riken.jp/Linux/centos/5/os/i386/CentOS/python-sqlite-1.1.7-1.2.1.i386.rpm
[root@foo yumrpm]# wget ftp://ftp.riken.jp/Linux/centos/5/os/i386/CentOS/python-urlgrabber-3.1.0-6.el5.noarch.rpm
[root@foo yumrpm]# wget ftp://ftp.riken.jp/Linux/centos/5/os/i386/CentOS/yum-fastestmirror-1.1.16-14.el5.centos.1.noarch.rpm
[root@foo yumrpm]# wget ftp://ftp.riken.jp/Linux/centos/5/os/i386/CentOS/yum-metadata-parser-1.1.2-3.el5.centos.i386.rpm

 

揃ったところでまとめてインストールしようとするとまた怒られる

[root@foo yumrpm]# rpm -ivh *
warning: python-elementtree-1.2.6-5.i386.rpm: Header V3 DSA signature: NOKEY, key ID e8562897
error: Failed dependencies:
        m2crypto >= 0.16-5 is needed by python-urlgrabber-3.1.0-6.el5.noarch

 

怒られたのをまた追加

[root@foo yumrpm]# wget ftp://ftp.riken.jp/Linux/centos/5/os/i386/CentOS/m2crypto-0.16-6.el5.8.i386.rpm

 

あらためて全部まとめてインストール

 

[root@foo yumrpm]# rpm -ivh *
warning: m2crypto-0.16-6.el5.8.i386.rpm: Header V3 DSA signature: NOKEY, key ID e8562897
Preparing... ########################################### [100%]
   1:yum-metadata-parser    ########################################### [ 13%]
   2:python-sqlite          ########################################### [ 25%]
   3:python-elementtree     ########################################### [ 38%]
   4:m2crypto               ########################################### [ 50%]
   5:python-urlgrabber      ########################################### [ 63%]
   6:python-iniparse        ########################################### [ 75%]
   7:yum-fastestmirror      ########################################### [ 88%]
   8:yum                    ########################################### [100%]

 

なんかwarning出てるけどとりあえず成功。

 

まずはアップデート実行。

[root@foo yumrpm]# yum update

初回なせいかアップデート対象は少ないのにやたら時間がかかる。

 

Updated:
  filesystem.i386 0:2.4.0-3.el5.centos      jwhois.i386 0:3.2.3-12.el5      m2crypto.i386 0:0.16-7.el5      quota.i386 1:3.13-5.el5
  rsyslog.i386 0:3.22.1-3.el5_6.1           screen.i386 0:4.0.3-4.el5       sed.i386 0:4.1.5-8.el5          shadow-utils.i386 2:4.0.17-18.el5_6.1
  tzdata.i386 0:2011g-1.el5

Complete!

 

15分ぐらいで無事完了。

 

…ただOSが32bit固定で選べなかったりと色々と不満が出てきたのでServerQueenはあっさり解約。

30日返金保証!とか書いてたけど

 

・お支払額 – 初期設定費用 – 振込み手数料 = ご返金額

¥8,820      ¥7,350         ¥420     ¥1,050

 

初期設定費用は返してくれんのかい。

初期設定費用高額やし高い割にはサーバー海外やし返金保証とかうたっといてこれかい。

もう使うことは無いですな。

Share on Facebook0Share on Google+0Tweet about this on TwitterShare on LinkedIn0

あわせて読みたい

Fatal error: Uncaught Exception: 12: REST API is deprecated for versions v2.1 and higher (12) thrown in /var/www/junkpot.net/tech/html/wp-content/plugins/seo-facebook-comments/facebook/base_facebook.php on line 1273