古い ubuntu のバージョンを使っていると apt-get update 404 Not Found が出てで失敗する

Share on Facebook0Share on Google+0Tweet about this on TwitterShare on LinkedIn0

インストールだけしてほったらかしにしてた母艦上のcoLinuxを活用しようと

久しぶりに接続してとりあえずアップグレードをやってみたら

タイトルのエラーが。

Err http://archive.ubuntu.com jaunty/main Packages
  404 Not Found [IP: 91.189.88.30 80]
Err http://archive.ubuntu.com jaunty/restricted Packages
  404 Not Found [IP: 91.189.88.30 80]
Err http://archive.ubuntu.com jaunty/universe Packages
  404 Not Found [IP: 91.189.88.30 80]
Err http://archive.ubuntu.com jaunty/multiverse Packages
  404 Not Found [IP: 91.189.88.30 80]
Err http://archive.ubuntu.com jaunty-updates/main Packages
  404 Not Found [IP: 91.189.88.30 80]
Err http://archive.ubuntu.com jaunty-updates/restricted Packages
  404 Not Found [IP: 91.189.88.30 80]
Err http://archive.ubuntu.com jaunty-updates/universe Packages
  404 Not Found [IP: 91.189.88.30 80]
Err http://archive.ubuntu.com jaunty-updates/multiverse Packages
  404 Not Found [IP: 91.189.88.30 80]

こんな感じで軒並みエラーに。

 

なんぞーと調べてみると古いバージョンは

リポジトリのURLが変わるようで、見に行くリポジトリのURLを変えれば直るらしい。

早速変更

root@colinux:~# vi /etc/apt/sources.list
deb http://archive.ubuntu.com/ubuntu jaunty main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu jaunty-updates main restricted universe multiverse

archive.ubuntu.com の部分を古いバージョン向けの

old-releases.ubuntu.com に変更して保存してー

root@colinux:~# apt-get update

再度実行

問題なくupdate完了ーっと

Share on Facebook0Share on Google+0Tweet about this on TwitterShare on LinkedIn0

あわせて読みたい

Fatal error: Uncaught Exception: 12: REST API is deprecated for versions v2.1 and higher (12) thrown in /var/www/junkpot.net/tech/html/wp-content/plugins/seo-facebook-comments/facebook/base_facebook.php on line 1273