WordPress 関連記事 (YARPP) がエラーに

Share on Facebook0Share on Google+0Tweet about this on TwitterShare on LinkedIn0

wordpress-plugin-300x300

 

WordPressの関連記事表示で有名なYARPPにアップデートが来てたもんで軽い気持ちでアップデートすると設定画面にエラーが。

修復できないエラーがどうたらと。

なんらかの原因でアップデートがうまくいかなくて手動でSQL叩いてやってくれと。

発行すべきSQLはちゃんとコピペ出来るようなページに誘導してくれてます。

で、早速言われたとおりにやると一個目でいきなりエラーが

mysql> ALTER TABLE wp_posts ADD FULLTEXT `yarpp_title` ( `post_title`);
ERROR 1214 (HY000): The used TABLE TYPE doesn't support FULLTEXT indexes

テーブルがFULLTEXT indexに対応してねーよと

調べてみるとFULLTEXT indexはテーブルのタイプがMYISAMでないと対応してないそうで。

mysql> SHOW CREATE TABLE wp_posts;

このSQLでテーブルタイプを見てみると

ENGINE=InnoDB

思いっきりInnoDB。

mysql> ALTER TABLE wp_posts ENGINE MYISAM;

これでテーブルタイプを変更してからページにあったSQLを全部実行してエラー解消っと。

YARPPは最近ばんばんアップデートされてるのでこのへんのエラーは最新版では修正されてそうですな。

Share on Facebook0Share on Google+0Tweet about this on TwitterShare on LinkedIn0

あわせて読みたい

Fatal error: Uncaught Exception: 12: REST API is deprecated for versions v2.1 and higher (12) thrown in /var/www/junkpot.net/tech/html/wp-content/plugins/seo-facebook-comments/facebook/base_facebook.php on line 1273